Database Management

A Handbook on Database Management
Database Management

- Attribute Data
- Entering and Coding Attribute data
- Linking Digital Map and Attribute Information
- Database and Database Management System
- Relational Database structure
Attribute data

- location, various descriptions of the object and dating

| Building map |

| Identity: building number |
| Location: Address |
| Representative coordinates |
| Description: Builder/owner |
| Status |
| Type |
| Function |
| water Supply |
| Available area |
| Date: Year built |

Attribute data
**Entering and Coding Attribute data**

- Establish an ID code between geometry and attribute
- Conserve computer memory
- Ease input work
- Simplify the searches for data

<table>
<thead>
<tr>
<th>Geometry</th>
<th>Attribute</th>
</tr>
</thead>
<tbody>
<tr>
<td>ID</td>
<td>ID</td>
</tr>
<tr>
<td>coordinates</td>
<td>Location</td>
</tr>
<tr>
<td>Topology</td>
<td>Description</td>
</tr>
<tr>
<td></td>
<td>Dating</td>
</tr>
<tr>
<td></td>
<td>Attribute</td>
</tr>
</tbody>
</table>
### Entering and Coding Attribute data

<table>
<thead>
<tr>
<th>Level1</th>
<th>Attribute</th>
<th>Level2</th>
<th>Attribute</th>
<th>Level3</th>
<th>Attribute</th>
</tr>
</thead>
<tbody>
<tr>
<td>100</td>
<td>Built-up</td>
<td>110</td>
<td>Industry</td>
<td>111</td>
<td>Light</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>112</td>
<td>Heavy</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>113</td>
<td>Others</td>
</tr>
<tr>
<td></td>
<td></td>
<td>120</td>
<td>Transportation</td>
<td>121</td>
<td>Railway</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>122</td>
<td>Airport</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>123</td>
<td>Parking</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>124</td>
<td>Terminal</td>
</tr>
<tr>
<td>200</td>
<td></td>
<td>210</td>
<td>Coniferous</td>
<td>211</td>
<td>Fir</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>212</td>
<td>Pine</td>
</tr>
<tr>
<td></td>
<td></td>
<td>220</td>
<td>Decedious</td>
<td>221</td>
<td>Oak</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>222</td>
<td>Beech</td>
</tr>
<tr>
<td></td>
<td></td>
<td>230</td>
<td>...........</td>
<td>231</td>
<td>....</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>....</td>
<td>....</td>
</tr>
</tbody>
</table>
Entering and Coding Attribute data

- Easily stored in tabular form - called tabular data
- Different data types stored in different table
- Number of column extended by linking another table using common assess key or entering data to same table.
- Table design independent of geometric data type

<table>
<thead>
<tr>
<th>ID</th>
<th>Landuse</th>
<th>Area</th>
<th>Township</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>123</td>
<td>22.67</td>
<td>0914</td>
</tr>
<tr>
<td>2</td>
<td>111</td>
<td>1.45</td>
<td>0916</td>
</tr>
<tr>
<td>...</td>
<td>321</td>
<td>46.80</td>
<td>0923</td>
</tr>
</tbody>
</table>
Linking Digital Map and Attribute Information

Digital map database

<table>
<thead>
<tr>
<th>Polygon no</th>
<th>Building</th>
<th>X coordinate</th>
<th>Y coordinate</th>
</tr>
</thead>
<tbody>
<tr>
<td>125</td>
<td>589</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Building database

<table>
<thead>
<tr>
<th>Polygon no</th>
<th>Lot no</th>
<th>Owner</th>
<th>Year built</th>
</tr>
</thead>
<tbody>
<tr>
<td>125</td>
<td>44/113</td>
<td>Peter</td>
<td>1995</td>
</tr>
</tbody>
</table>

Land Register

<table>
<thead>
<tr>
<th>Lot no</th>
<th>Property owner</th>
<th>Land area</th>
<th>Property address</th>
</tr>
</thead>
<tbody>
<tr>
<td>44/113</td>
<td>Jerry</td>
<td>Peter</td>
<td>1/1099, Anthill..</td>
</tr>
</tbody>
</table>

Linking by ID
**Linking Digital Map and Attribute Information**

![Diagram showing linking by geometry]

<table>
<thead>
<tr>
<th>ID</th>
<th>Building no.</th>
<th>Polygon</th>
<th>Property</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>559</td>
<td>A</td>
<td>44/110</td>
</tr>
<tr>
<td>2</td>
<td>600</td>
<td>C</td>
<td>44/95</td>
</tr>
<tr>
<td>3</td>
<td>610</td>
<td>B</td>
<td>44/121</td>
</tr>
<tr>
<td>4</td>
<td>156</td>
<td>D</td>
<td>44/81</td>
</tr>
<tr>
<td>5</td>
<td>642</td>
<td>C</td>
<td>44/78</td>
</tr>
</tbody>
</table>

**Linking by geometry**
**Database and Database Management System**

**Database:**
- Sets of collection of information
- Files structured by DBMS and accessed through it
- DBMS located between the physical storage and the user.
**Database and Database Management System**

**DBMS**: 
- Software package for storage, manipulation, retrieval of data from a database.
- To handle complex task of multiple files
- Located between the physical storage and the user.

![Diagram showing relationships between Interactive questions, Questions translation, Database Process, Management of stored data, System Catalog, and Database.]
Relational Database structure

<table>
<thead>
<tr>
<th>Building ID</th>
<th>property</th>
<th>Owner</th>
<th>Year</th>
<th>Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>234</td>
<td>44/110</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>256</td>
<td>44/50</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>298</td>
<td>44/19</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>property</th>
<th>Owner</th>
<th>Area</th>
<th>Address</th>
</tr>
</thead>
<tbody>
<tr>
<td>44/50</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>44/110</td>
<td>John</td>
<td>6400</td>
<td>33 ...</td>
</tr>
<tr>
<td>44/19</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Relational Database structure
- Geographical object in a record
- Attribute in a set of fields
- Three basic attributes
  primary key
  relational join
  normal forms
- Most frequently used for attribute data
- Simple, flexible structures
Relational Database structure

- search time is longer
- collection of large number of table for complex relationships
- Stores single value for each cell
Exercise

1. Database file handling
2. Selection
3. Preparation of Sub-Set
4. Database query
5. Calculation
1. Database file handling

1.1 Loading existing data
1.2 Creating point data
1.3 Input / Edit attribute data
1.4 Join tables
1.5 Link tables
1.1 Loaded existing data

- Double click the icon or go to Menu Start menu
- Click at Add Theme icon
- Select theme name “district.shp” then click OK.
Open attribute table of theme “District.shp”

- Activate theme

- Click

<table>
<thead>
<tr>
<th>Shape</th>
<th>Pcode</th>
<th>Dcode</th>
<th>Dname</th>
<th>Sq_m</th>
<th>Sq_km</th>
</tr>
</thead>
<tbody>
<tr>
<td>Polygon</td>
<td>13</td>
<td>1312</td>
<td>Vilabouri</td>
<td>1765107479.680</td>
<td>1765.107</td>
</tr>
<tr>
<td>Polygon</td>
<td>13</td>
<td>1311</td>
<td>Xaibouri</td>
<td>895345602.959</td>
<td>895.946</td>
</tr>
<tr>
<td>Polygon</td>
<td>13</td>
<td>1313</td>
<td>Atsaphon</td>
<td>1452316046.602</td>
<td>1452.316</td>
</tr>
<tr>
<td>Polygon</td>
<td>13</td>
<td>1305</td>
<td>Xepon</td>
<td>2266782030.519</td>
<td>2266.782</td>
</tr>
<tr>
<td>Polygon</td>
<td>13</td>
<td>1302</td>
<td>Outhoumphon</td>
<td>1082417234.996</td>
<td>1082.417</td>
</tr>
<tr>
<td>Polygon</td>
<td>13</td>
<td>1315</td>
<td>Phalanxai</td>
<td>998076585.390</td>
<td>998.077</td>
</tr>
<tr>
<td>Polygon</td>
<td>13</td>
<td>1303</td>
<td>Atsaphangthong</td>
<td>700937798.695</td>
<td>700.938</td>
</tr>
<tr>
<td>Polygon</td>
<td>13</td>
<td>1304</td>
<td>Phin</td>
<td>337212452.212</td>
<td>3372.125</td>
</tr>
<tr>
<td>Polygon</td>
<td>13</td>
<td>1301</td>
<td>Khantabouri</td>
<td>681611273.958</td>
<td>681.611</td>
</tr>
<tr>
<td>Polygon</td>
<td>13</td>
<td>1309</td>
<td>Champhon</td>
<td>1049758789.065</td>
<td>1049.759</td>
</tr>
<tr>
<td>Polygon</td>
<td>13</td>
<td>1306</td>
<td>Nong</td>
<td>1700596082.260</td>
<td>1700.596</td>
</tr>
<tr>
<td>Polygon</td>
<td>13</td>
<td>1310</td>
<td>Xonbouri</td>
<td>1205959535.145</td>
<td>1205.960</td>
</tr>
</tbody>
</table>
1.2 Creating point data

- Click at Table icon then click Add button
- Select a table file name “dh.dbf”
- Activate View window
- Go to View menu and select Add Event Theme
- Choose table name “dh.dbf” and X,Y coordinate
- Go to Theme menu and select Convert to Shapefile
- Navigate the working directory and set a new name “district_hospital” and click OK
1.3 Input / Edit attribute data

- Open table of “District_hospital.shp”
- In Table menu, select Start Editing
- Click at field name “Dcode”
- Then click Sort Ascending button
- Select Edit button and click in Dname at Dcode = 1302
- Type new Dname to “OUTHOUMPHONE”
- Select Add Field in Edit menu
- Select Name and Type of Field
- Click OK

- Click at Pcode field name
- Select Calculate button
- In Field Calculator window type “13” then Click OK

- Save Edits and Stop Editing in Table menu
1.4 Join tables

- Select Table icon
- Click Add button
- Select a table file name “soc-eco.dbf”
- Click OK
- Open attribute table of theme “District.shp”
- Click Dcode filed name of “Soc-eco.dbf” then Click Dcode filed name of “District.dbf”

- To join two table, Click Join button
- Check attribute table of “District.shp” with new joined table

<table>
<thead>
<tr>
<th>Poade</th>
<th>Dcode</th>
<th>Dname</th>
<th>Sq_m</th>
<th>Sq_km</th>
<th>Province</th>
<th>Litter</th>
<th>Water_1k</th>
<th>Pipe_1k</th>
<th>Elect_1k</th>
<th>HH</th>
</tr>
</thead>
<tbody>
<tr>
<td>13</td>
<td>1312</td>
<td>Vilabouri</td>
<td>1765107479.580</td>
<td>1765.107</td>
<td>SAVANNAKHET</td>
<td>6635</td>
<td>3913</td>
<td>24</td>
<td>24</td>
<td>318</td>
</tr>
<tr>
<td>13</td>
<td>1311</td>
<td>Xabouri</td>
<td>895945602.359</td>
<td>895.946</td>
<td>SAVANNAKHET</td>
<td>20799</td>
<td>6926</td>
<td>60</td>
<td>319</td>
<td>6056</td>
</tr>
<tr>
<td>13</td>
<td>1313</td>
<td>Atsaphon</td>
<td>1452316034.502</td>
<td>1452.316</td>
<td>SAVANNAKHET</td>
<td>14735</td>
<td>6390</td>
<td>41</td>
<td>40</td>
<td>6390</td>
</tr>
<tr>
<td>13</td>
<td>1305</td>
<td>Xepon</td>
<td>2266782030.519</td>
<td>2266.782</td>
<td>SAVANNAKHET</td>
<td>7393</td>
<td>6186</td>
<td>19</td>
<td>32</td>
<td>4943</td>
</tr>
<tr>
<td>13</td>
<td>1302</td>
<td>Outhoumpothon</td>
<td>1092417234.996</td>
<td>1092.417</td>
<td>SAVANNAKHET</td>
<td>25973</td>
<td>9708</td>
<td>87</td>
<td>1145</td>
<td>7633</td>
</tr>
<tr>
<td>13</td>
<td>1315</td>
<td>Phalanxi</td>
<td>998076585.390</td>
<td>998.077</td>
<td>SAVANNAKHET</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>13</td>
<td>1303</td>
<td>Atsaphangthong</td>
<td>700537798.595</td>
<td>700.938</td>
<td>SAVANNAKHET</td>
<td>16486</td>
<td>7697</td>
<td>274</td>
<td>1020</td>
<td>7662</td>
</tr>
<tr>
<td>13</td>
<td>1304</td>
<td>Phin</td>
<td>337212452.212</td>
<td>3372.125</td>
<td>SAVANNAKHET</td>
<td>10385</td>
<td>5648</td>
<td>30</td>
<td>45</td>
<td>5498</td>
</tr>
<tr>
<td>13</td>
<td>1301</td>
<td>Khanthabouri</td>
<td>681611273.958</td>
<td>681.611</td>
<td>SAVANNAKHET</td>
<td>6144</td>
<td>16543</td>
<td>5472</td>
<td>7597</td>
<td>11822</td>
</tr>
<tr>
<td>13</td>
<td>1309</td>
<td>Champhon</td>
<td>1049758799.065</td>
<td>1049.759</td>
<td>SAVANNAKHET</td>
<td>35634</td>
<td>13806</td>
<td>323</td>
<td>1815</td>
<td>13686</td>
</tr>
<tr>
<td>13</td>
<td>1306</td>
<td>Nong</td>
<td>170059608.260</td>
<td>1700.596</td>
<td>SAVANNAKHET</td>
<td>1731</td>
<td>2729</td>
<td>10</td>
<td>7</td>
<td>2656</td>
</tr>
<tr>
<td>13</td>
<td>1310</td>
<td>Xombung</td>
<td>120559535.145</td>
<td>1205.960</td>
<td>SAVANNAKHET</td>
<td>11508</td>
<td>4984</td>
<td>35</td>
<td>110</td>
<td>4984</td>
</tr>
<tr>
<td>13</td>
<td>1314</td>
<td>Xaphouthong</td>
<td>454822633.252</td>
<td>454.823</td>
<td>SAVANNAKHET</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>13</td>
<td>1308</td>
<td>Songkhon</td>
<td>163561839.466</td>
<td>1635.817</td>
<td>SAVANNAKHET</td>
<td>45533</td>
<td>12818</td>
<td>442</td>
<td>435</td>
<td>11813</td>
</tr>
<tr>
<td>13</td>
<td>1307</td>
<td>Thapengthong</td>
<td>2115552184.356</td>
<td>2115.852</td>
<td>SAVANNAKHET</td>
<td>7274</td>
<td>3242</td>
<td>104</td>
<td>24</td>
<td>3242</td>
</tr>
</tbody>
</table>

- To cancel joined table, click Remove All Joins in Table Menu.
1.5 Link tables

Linking option is used in case of one-to-many relationship. For example, we want to link to the database of district boundary to village coverage weather to know the village information by district.

- Add table of “District.shp” and “Village.shp”
- Click on field name “Dcode” of Village’s table first
- Then click field name “Dcode” of district’s table
- Select “Link” in Table menu
Two tables are linked together, then we can select a record of district.
- Click Dcode = 1306 in district’s table.
- Automatically select to records of Village which use same district’s code.

Number of villages fall in Nong’s district
2. Selection

2.1 Identify features

2.2 Select features

2.3 Select records

2.4 Select by themes
2.1 Identify features

- Activate theme name “District.shp”
- Click Identify button then click on a feature of district theme

All information included joined data
2.2 Select features

- Click Select Feature button
- Clicking on a feature of district theme
- Open table of district.shp
- Click Promote button to make the selected record shows on top.
2.3 Select records

- Activate “District.shp” Table
- Click Select button
- Clicking on records which Dcode = 1301 to 1305. Hold SHIFT key to select many records
- Try a set of Selection Tool
2.4 Select by themes

- Select district name “Kanthabouri”
- Add theme “Village.shp”
- Go to theme menu, Select By Theme
- Activate “Village” theme
- Choose input options as below

- Then click New Set
- Open table of “Village” and check number of villages within the district
3. Preparation of Subset

3.1 Creating subset shapefiles
3.2 Creating subset databasefiles
3.1 Creating subset shapefiles

Once villages of Khanthabouri have been selected, we want the selection into separate shapefile.

- Activate theme “Village.shp” which have been selected within Khanthabouri district
- Go to Theme menu and select Convert to Shapefile
- Navigate the working directory and set a new name “vill_ktb” and click OK

- Add new theme “vill_ktb” on View Window
3.2 Creating subset databasefiles

This step we will create subset database file of population for Khanthabouri district.

- Add Theme name “pop95_vill.shp and “district.shp”
- Select Khanthabouri district feature
- Select “pop95_vill” feature within the district
- Open the selected “Pop95_vill” table
- Select Export from File menu
- Choose dBase as Export format, Click OK
- Navigate to working directory and input a new name, Click OK
- Add table "Pop95_ktb.dbf" and open table of "Vill_ktb.shp" theme
- Join two table and save as a new shapefile (Covert to Shapefile)
4. Database query

4.1 Build query expressions
4.2 Database query (single/multiple)
4.1 Build query expressions

Building a query expression is a powerful way to select features which fulfill certain conditions.

- Add theme “district.shp”
- Click Query Builder button
- Double click field’s name and input an expression

- Query district name = khanthaburi
- Click New Set button
- Query district name = “Xaibouri”
- Then click Add To Set button

- Query more district name “Outoumphon” and “Xaiphouthong”
To find districts which has an area < 3,000 Sq.Km. but > 1,000 Sq.Km.

- Activate “district.shp”
- Click Query Builder button.
- Input an expression
  `([Sq_km] > 1000) and ([Sq_km] < 3000)`
- Double click in the list of fields, Operator and Values
- Click New Set
4.2 Database query (multiple)

How to query multiple database tables in the same time?
- Create a new “district” theme which already joined with table “Soc-eco.dbf” (step 1.4). Save new theme as “Social_dist”
- Add theme “Social_dist” to a View window
- Click Query Builder button. Input an expression
  \[(\text{Liter} < 10000) \land (\text{Water\_hh} \leq 4000) \land (\text{Elect\_hh} \leq 30)\]
5. Calculation

5.1 Statistic
5.2 Aggregation data
5.3 Statistic
5.1 Statistic

This step we would like to see statistic information of total population of attribute table “Pop95_vill.shp”

- Add table of “Pop95_vill.shp”
- Activate field name “Sumtotpe”
- Click Field and Statistic
- The statistic information of the field will be displayed
- Click OK to close the window
5.2 Aggregation data

In the population database we have information for each village on population, number of population by district

- Open attribute table of Pop95_vill.shp
- Activate the table and click on field’s name “Dcode”
- Select Summarize in Field menu
- Once Summary Table Definition loaded
- Click Save As to navigate output file’s directory

- Select Field name “Sum_Sumoftotma”
- Select a method to summarize
- Click add
-Select others field ; “Sum_Sumoftotfe” and “Sum_Sumoftotpe”. Click Add
-Click OK to finish aggregations
-If there are some unnecessary fields have been added. The fields can be deleted by clicking on those fields and click Delete button.

-Add “sumpop_district.dbf”
-Try more aggregations fields using others method such as Average, Minimum, Maximum, etc.
5.3 Calculator

In order to calculate percentage of number of male and female by district which we have created from the previous steps.

- Activate table name “sumpop_district.dbf” which we have created from the previous steps.
- Click Start Editing in Table menu
- Add two fields name “Percent_M” and “Percent_F” with be in “Number” type, “7” width and “2” decimal places
- Activate on “Percent_M” field name
- Select Calculate in Field menu
- Input an expression
Do the same expression to calculate percentage of number of female population by district

- Activate “Percent_F” field name
- Click Calculator button
- Input an expression as follow

\[ \frac{\text{Sum}_\text{Sumoftotfe}}{\text{Sum}_\text{Sumoftotpe}} \times 100 \]

- Click OK

- Select Save Edits in Table menu
- Click Stop Editing